Resolved
We've fixed the underlying source of data delays and updating data in agents and the app should now work as expected.
Identified
We have identified the source of the issue and are working to deliver a fix.
Investigating
We are investigating an issue where some updates are not being reflected in the interface, or when chatting with your Agent.